4757 days ago |
I noticed this contradiction, too... :) If we're not going to use c[ad]r composability, why not just use unique, easily distinguishable names for all of these that don't compose:
car --> hd cdr --> tl caar --> inner cddr --> skip2 cadr --> second
...or something like that. Unique names would reduce errors.